ID:2683346
 
I've been hosting Pondera for awhile now, but I've noticed that it will stop showing the live server in the Byond Hub, sort of like a shadowban, preventing players from seeing or joining my game. I've tried sitting in the server to keep it active but it still happens.

Why does this happen? Why won't the game show up with a live server in the Hub?

Is Byond broken? Its ancient internet infrastructure are creating issues that are not resolved and it is breaking the entire framework that allows byond to function as a centralized game community?

People might not want to give my game a chance, they may not want to play it, but there is no acceptable reason that the live server I am spending resources hosting shouldn't show up in the Hub (which is the entire point of Byond). With the live server not showing up, it completely negates ANY opportunity for people to give my game a chance which is wholly unfair and defeats the very foundation of Byond. Build Your Own Net Dream doesn't mean "Be relegated to the shadows of obscurity because we don't like you/want you to be visible".

Could it potentially be the slowness of the refresh for the Hub data sent by the server? When will Byond update its internet backbone? Http is obsolete.
There are lots of reasons that your game might not be appearing on the hub. You could have a poor connection (living in a rural area), there could be something amiss with the world you're trying to host, it might just be that you accidentally mucked up a setting somewhere in Dream Daemon.

I think your best course of action here is to send some friends a direct link to your game and see if they're able to join it through there, then start working from there to rule out other possibilities.

BYOND has not, does not, and never will, moderate the listings of its hubs based off of anything other than legal or safety concerns. Unless your game violates any of the terms of service or you won't be delisted from the hub.
AERProductions wrote:
Why does this happen? Why won't the game show up with a live server in the Hub?

Most typically this seems to be a problem where the server simply loses touch with the hub and thinks it can't reach the hub anymore. This is supposed to self-correct, but there are rare cases where it doesn't and I have yet to be able to reproduce this reliably.

Could it potentially be the slowness of the refresh for the Hub data sent by the server? When will Byond update its internet backbone? Http is obsolete.

The hub doesn't use HTTP; that's just the website.
I think it might be related to my world.status update. Thankfully the game is currently being reprogrammed by a gracious contributor and we'll see if that clears things up a bit. If it wasn't the status update, then it may simply be how inefficient other aspects of my old source were. Thanks for the responses.

Login to reply.